Ye blog of Adam Wright

DIY, tutorials, stuff for geeks, all updated when I have the time to spare.

How to install Google Chrome in Ubuntu 10.04

I recently made the switch from Firefox to Chrome, and decided to install it on all my machines. I had some problems getting it installed for Ubuntu 10.04 at first, but then I found this post that spelled it all out.

Here’s the steps in simple, copy/paste format:

wget -q -O - https://dl-ssl.google.com/linux/linux_signing_key.pub | sudo apt-key add -
sudo sh -c 'echo "deb http://dl.google.com/linux/chrome/deb/ stable main" >> /etc/apt/sources.list.d/google.list'
sudo apt-get update -y
sudo apt-get install -y google-chrome-stable

Or if you’d like one long line:

wget -q -O - https://dl-ssl.google.com/linux/linux_signing_key.pub | sudo apt-key add - && sudo sh -c 'echo "deb http://dl.google.com/linux/chrome/deb/ stable main" >> /etc/apt/sources.list.d/google.list' && sudo apt-get update -y && sudo apt-get install -y google-chrome-stable

That should work.

Again, thanks to UbuntuUpdates for original post: UbuntuUpdates – PPA: Google Chrome
C
heck them out for more PPA sources and install tutorials!

Advertisements

2 responses to “How to install Google Chrome in Ubuntu 10.04

  1. divya 03/30/2015 at 1:43 PM

    divya@ubuntu:~$ sudo apt-get install -y google-chrome-stable
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    google-chrome-stable: Depends: gconf-service but it is not installable
    Depends: libasound2 (>= 1.0.23)
    Depends: libgconf-2-4 (>= 2.31.1) but it is not installable
    Depends: libgdk-pixbuf2.0-0 (>= 2.22.0) but it is not installable
    Depends: libglib2.0-0 (>= 2.26.0) but 2.24.1-0ubuntu2 is to be installed
    Depends: libgtk2.0-0 (>= 2.24.0) but 2.20.1-0ubuntu2.1 is to be installed
    Depends: libnspr4 (>= 1.8.0.10) but it is not installable
    Depends: libnss3 (>= 3.14.3) but it is not installable
    Depends: libstdc++6 (>= 4.6) but 4.4.3-4ubuntu5.1 is to be installed
    Depends: libx11-6 (>= 2:1.4.99.1) but 2:1.3.2-1ubuntu3.1 is to be installed
    Depends: libxfixes3 (>= 1:5.0) but 1:4.0.4-1 is to be installed
    Depends: libappindicator1 but it is not installable
    E: Broken packages

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: